Jump to content

Custom Search







Welcome to Dodge Caravan Forum


Sign In  Log in with Facebook

Create Account
Welcome to Dodge Caravan Forum, like most online communities you must register to create a topic or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Dodge Caravan Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members.
  • Create a photo album and post images. . .more!
Posted Image
 
Guest Message by DevFuse

Photo
- - - - -

gauge cluster not working


  • Please log in to reply
No replies to this topic

#1 trader82935

trader82935

    New Caravan Member

  • Caravan Member
  • Pip
  • 2 posts
  • Region:U.S. Mountain
  • Locationwyoming
  • Current Vehicle:1998 grand caravan

Posted 06 August 2017 - 03:24 AM

Hello everyone. I have a 1998 grand caravan and the gauge cluster just went haywire.  None of the gauges are working and the odometer reads 060 and on the gear selector side it only lights up D3L.  I have checked the fuses they are all good.  The odometer and gear selector stay lit up even with the key off and is killing the battery.  I read a forum about testing the gauges by holding trip and reset when turning the ignition on but it does not work. Any help would be greatly appreciated. Thanks in advance.









Lose this advertisement by becoming a member. Click here to create a free account.




Privacy Policy Terms of Service ·